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Introduction

OVERVIEW

Introspect Technology’s DRAM Test Suite is the complete solution for performing device initialization
and configuration, training, transmitter and receiver characterization, and functional testing on a DDR5
DRAM test bench. The test suite targets the SV5C 32 channel bidirectional system to drive the DRAM
command address bus, as well as generate write traffic and capture read bursts.

QUICK START DOCUMENTATION

This Quick Start Guide will provide the information required for a user to set up the DDR5 DRAM test
bench by providing detailed descriptions and diagrams for all the required connections.

HARDWARE REQUIREMENTS

e (QTY =1) SV5C-12 32 channel bidirectional system

e (QTY =1) 2 port programmable power supply

e (QTY = 8) Huber+Suhner MXP to SMA female cables (Introspect part # 4813)

e (QTY = 3) Huber+Suhner MXP to MXP cables (Introspect part # 4814)

e (QTY = 22) SMA male to SMA male adapters (example manufacturer part # - Amphenol RF
132168)

e (QTY = 10) 8" matched SMP to SMA cables (Introspect part # 4818)

e (QTY =2) 50 Ohm Term (example manufacturer part # — Mini-Circuits ANNE-50+
TERM/SMA-M/18GHZ RoHS)

e (QTY = 2) DC Block (example manufacturer part # — Mini-Circuits BLK-89-S+
DC BLOCK/SMA-F/SMA-M/RoHS)

e (QTY = 1) PC for running the Introspect ESP Software

NOTE ABOUT HARDWARE

The hardware requirements list assumes the DRAM interface signals are accessible via 3 MXP
connectors on the board, and cables are selected to minimize delays through the test bench. If
different connectors or cables are required, please contact Introspect Technology via the Service
Desk for assistance (https://introspect.atlassian.net/servicedesk/customer/portals).

DDRS5 DRAM Test Suite User Guide
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Test Bench Setup

SV5C 32 CHANNEL BIDIRECTIONAL SYSTEM

The SV5C 32 channel bidirectional system requires a special form factor, and it also requires unique
connections between the two SV5C units for synchronization. Follow the instructions in the document
"EN-GO45E-E-20078 SV5C 32 Channel Quick Start Guide”, using the provided form factor folder
“SV5C_32C12G_BIDIR_DDR" in place of the one referenced in the document ("SV5C_32C12G_DDR"). The
SV5C units will be hereafter referred to as Box 1 and Box 2, as per the definition in the above-mentioned
document.

SV5C BIDIRECTIONAL KIT CONTROL BUS

The SV5C Bidirectional Kit control bus is connected to the Box 1 SV5C, as shown in Figure 1.

SV5C Box 1 GPIO Pin 1 Bidirectional Kit GPIO
Box 1SV5 Pin6 < SV5 BDK Pin 11 1 ,/ \\
Box 1SV5 Pin7 4 SV5BDK Pin 1 0 %50 000s r & Sutuindeiet -4
Box 1 SV5 Pin 8 < SV5 BDK Pin 10 | T I

Box 1SV5Pin9 <« SV5BDKPin9
Box 1 SV5 Pin 10 «—» SV5 BDK Pin 2

Figure 1: Pin diagram of SV5C to SV5C Bidirectional Kit GPIO jumper cables

POWER SUPPLY

The power requirement is specific to the test board that is used, but typically there are two supply
channels at 1.8V and 1.1V for the VPP and VDD power rails. Connect the channels, ensuring the polarity
of the supplies are correct, and connect all the grounds.
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DRAM COMMAND ADDRESS BUS

Refer to Table 1 and Table 2 for the mapping of the SV5C channels to the pins on the test board. For a
mapping of the SV5C channel numbers to pin numbers on the MXP connectors, refer to the SV5C data
sheet listed in the references section at the end.

TABLE 1: SV5C TX CHANNEL TO DRAM SIGNAL MAPPINGS

SV5C CHANNEL DRAM SIGNAL NAMES

TX1P CK_T
TX1IN CK_C
TX2P RST
TX3P CSN
TX4P CAO
TX5P CAl
TX6P CA2
TX7P CA3
TX8P CA4
TX9P CAS
TX10P CAG6
TX11P CA7
TX12P CA8
TX13P CA9
TX14P CA10
TX15P CAll
TX16P CAl12
TX17P CA13
TX18P TDQSt/DM
TX19P TDQSc

DDRS5 DRAM Test Suite User Guide
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TEST BENCH SETUP

TABLE 2: SV5C RX CHANNEL TO DRAM SIGNAL MAPPINGS

‘ DRAM SIGNAL NAMES

SV5C CHANNEL

RX1P LBDQ

RX1IN Connect to DC block and 50 Ohm term
RX2P LBDQS

RX2N Connect to DC block and 50 Ohm term

DRAM DATA BUS
Refer to Table 3 for a mapping of the SV5C channels to the SV5C Bidirectional Kit (BDK) and to the pins

on the test board.

TABLE 3: SV5C BIDIRECTIONAL KIT TO DRAM SIGNAL MAPPINGS

SV5C BOX 2 BDK MXP BDK SMP DRAM SIGNAL
CHANNEL CHANNEL CHANNEL CHANNEL NAME
TX21P TX5P TX1P DUT1 DQST
TX21IN TX5N TXIN - -
RX21P RX5P RX1P - -
RX21N RX5N RX1IN - -
TX22P TX6P TX2P DUT2 DQSC
TX22N TX6N TX2N - -
RX22P RX6P RX2P - -
RX22N RX6N RX2N - -
TX23P TX7P TX3P DUT3 DQO
TX23N TX7N TX3N - -
RX23P RX7P RX3P - -
RX23N RX7N RX3N - -
TX24P TX8P TX4P DUT4 DQ1
TX24N TX8N TX4N - -
RX24P RX8P RX4P - -

DDRS5 DRAM Test Suite User Guide
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RX24N RX8N RX4N - -
TX25P TX9P TX5P DUT5 DQ2
TX25N TX9N TX5N - -
RX25P RX9P RX5P - -
RX25N RX9N RX5N - -
TX26P TX10P TX5P DUT6 DQ3
TX26N TX10N TX5N - -
RX26P RX10P RX5P - -
RX26N RX10N RX5N - -
TX27P TX11P TX6P DUT7 DQ4
TX27N TX11N TX6N - -
RX27P RX11P RX6P - -
RX27N RX11N RX6N - -
TX28P TX12P TX7P DUT8 DQ5
TX28N TX12N TX7N - -
RX28P RX12P RX7P - -
RX28N RX12N RX7N - -
TX29P TX13P TX8P DUT9 DQ6
TX29N TX13N TX8N - -
RX29P RX13P RX8P - -
RX29N RX13N RX8N - -
TX30P TX14P TX9P DUT10 DQ7
TX30N TX14N TX9N - -
RX30P RX14pP RX9P - -
RX30N RX14N RX9N - -
DDR5 DRAM Test Suite User Guide
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TEST BENCH CONNECTION DIAGRAM

Figure 2 shows a complete diagram of the SV5C 32 channel bidirectional system for DRAM testing.

/ o o |} par74

)= paol
e
SV5 Box 2 [ wxe ] > CA13, TDQSt, TDQSc
Bidirectional Kit Control Bus
(e —) CA[12:9]
[wee ] CA[8:5]
[ wxr ] » CA[4:1]
SV5 Box 1 MXP CK, RST, CSN, CAO

| LBDQ, LBDQS

Figure 2: SV5C 32 Channel Bidirectional System for DRAM Testing
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Using the DRAM Test Suite

NOTE ON SOFTWARE VERSION

The version of the Introspect software that should be used will depend on the version of the
DRAM Test Suite. Please contact Introspect Technology via the Service Desk for this information
(https://introspect.atlassian.net/servicedesk/customer/portals).

GETTING STARTED

USING THE INTROSPECT GUI

Open the test suite in the Introspect ESP Software GUI with the “SV5C_32C12G_BIDIR_DDR" form factor
as in Figure 3.

n TestBrowser - ] X
Look under Folder: lC:\DDRS_DRAM_Tat_Suie_D.ZO v[ | Add Folder |
Fitter:
Test folder contains:
L name contains: | ] Con Faer
Test uses component: | (Any) =
Apply Fiter
Introspect ESP X Test contains string: ’ ‘ e
—~~
incrospect Nomo i
N vechnology DDR5_DRAM_Test_Sutte_0.2.0 04/26/2021 16:04:14

Welcome to Introspect ESP (v 21.2.0)

To namow down the choices in the menu below,
type part of the desired form factor name in the "Filter” box.

Fiter: ‘ |

Choose the IESP form factor '

SV5C_32C12G_BIDIR_DDR v

Info about Preferences

@ Selected Test: |DDR5_DRAM_Test_Suite_0.2.0 ] Show Test Folder
< Bad\
# SVT Test A

# SVT version 21.2.0

# Test saved 2021-03-25_1201

g :%n factor: SV5C_32C12G_BIDIR_DDR_2

# Checksum: 1a1a5b38c30680106aa61adde 1ca584a

# Note: This file is the ‘Save'file for the Test.

# I should not be used as a standalone Python script.

ol Rid # ~an ha vead vis nn QAT R
@:n | Cancel

Figure 3: Opening the DRAM Test Suite in the Introspect ESP Software GUI

DDR5 DRAM Test Suite User Guide
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USING AN EXTERNAL PYTHON SCRIPT

The DRAM Test Suite functionality may be accessed from an external python script by following the
steps below:

1. Install the correct Python version and modules, by referring to the sections “Python Version”
and "Required Python Modules” in the document
“UsingComponentsinExternalPythonScripts.pdf”. This document can be found inside the
Introspect GUI under Help->Application Notes->Script User Manual.

2. Edit the python module search path in “dramTestSuiteScript.py” (located in the
TestAsPythonScript subfolder of the test suite) to point to SvtPython in the Introspect GUI
installation folder

svtPythonPath = <iespInstallPath>\SvtPython

and edit the FTDI serial numbers to match those in the custom form factor file
"Documents\Introspect\Config\CustomFormFactors\SV5C_32C12G_BIDIR_DDR\config.csv".

ftdiSerialNums = ['FTDI:INSV5M20050020A', 'FTDI:INSV5M20050020B"',
'"FTDI:INSVS5M1I9110010A"', 'FTDI:INSV5M19110010B']

Alternatively, both these steps can be performed automatically by opening the test procedure
in the Introspect GUI and clicking File->Save.

3. The DRAM Test Suite functionality can now be used externally by importing the test suite
module as below.

import sys

testSuitePath = r'<ddr5DramTestSuitePath>\TestAsPythonScript'
sys.path.append (testSuitePath)

import dramTestSuiteScript

DR5 DRAM Test Suite User Guide

INTROSPECT.CA 10
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TEST SUITE CODE

The DRAM Test Suite provides everything required for performing transmitter and receiver
characterization and functional testing on a DRAM, including the steps to initialize the device and bring
it to a functional state. The pre-built functions defined in “"dramTestSuite.py” in the PythonCode folder of
the test procedure, along with the DdrDramController component in the Introspect ESP software, can be
used to build a custom test script that exercises the DRAM device under test. A simple example of such a
test script is shown in Figure 4.

Test Procedure  nitialize Dram Test Suite

1l iesp = getIespInstance()
2 initializeDramTestSuite ()

o Customize test suite run below

5 turnCnPowerSupplyOutputs () dramController.setup initializes the interface
€ and runs training

7 dramController.setup()

8 bzamCom::oller .sendMpc (0x7F, rank=0, multicycle=True)
9
10 rxDgVoltageSensitivity(channel="'DQ0"')
11 txDgEyeScan (channel="DQ0"') }
12
13 turnOffPowerSupplyCutputs ()

Call pre-built functions from “dramTestSuite.py”

Figure 4: Example Test Procedure Using the DDR5 DRAM Test Suite

DRAM CONTROLLER

The DdrDramController component class provides an interface for communicating with the DRAM
device under test. It handles all initialization, configuration, and training of the DRAM, as well as
providing a simple API for sending test patterns and commands. The software also provides several
parameter components that can be linked to the DdrDramControllerto customize the DRAM interface,
as in Figure 5. The full API documentation for the DdrDramController and other related components can
be found inside the Introspect GUI under Help->Component Classes.

DDR5 DRAM Test Suite User Guide
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SUMMARY

Components ‘ dramController properties (dlass: DramController)
ddrBdkChannelLabeling deviceSeralNum
Labeing phyParams
dramController
dramParams
initialize Dram Test Suite r«ChannelLabeling eli
phyParams txChannelLabeling
puwerSLpplyVlglni:mlerl bdkChannelLabeling ddrBdkChannel
erhmnelLabdrg calibrateZq True dramParams properties (class: DramParams)
testAsPython Script trainingDataCsPhase auto coRate mode2N
trainingDataCaPhase auto burstLengthMode BL16
training DataCsVref auto dasRttPark ::3"'"
. groupACaOat
trainingDataCaVref auto FoupACKOR OF
trainingDataRead auto groupACsOc MOF
trainingDataDaq Ve auto mm tt400hm
. groupl #400hm
trainingDataWrite auto aroupBCsOR 144006m
trainingDataFolderPath readLatency %
calibratedCommand ToData Skew 1505.49 readPostambleMode ul_OD
readPreambleMode pat_1|
calibratedDataBusLatency 1505.49 i R g
saveResults True witePreambleMode pat_0010
W t600hm
tPark #600hm
refCsintialVake 45
vrefC: 45
saveResults vrefDgntialVake 45
Is saving of results desired? (True/False) ““"B“Dm ;L
— enableDatal
Add || Remove | | Cog | e st e e
regFie dramRegFile ini

Figure 5: Customizing the DRAM controller interface

Summary

This document described the Introspect Technology DRAM Test Suite, which is a complete solution for
testing and training a DDR5 DRAM device under test. It enables performing device initialization and
configuration, training, transmitter and receiver characterization, and functional testing on a DDR5
DRAM test bench. The document described the hardware connection diagrams in detail and provided

simple step-by-step instructions to starting the test suite and using it.

DDR5 DRAM Test Suite User Guide
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TABLE 4: REFERENCES

DATA SHEET

SV5C Data Sheet MK-DO014E-E-20063

USER GUIDES
SV5C 32 Channel Quick Start Guide EN-GO45E-E-20078

DDR5 DRAM Test Suite User Guide
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